Pedido de ajuda aos electrónicos do fórum

Página 1 de 2 12 ÚltimaÚltima
A mostrar resultados 1 para 30 de 32
Like Tree8Likes

Título: Pedido de ajuda aos electrónicos do fórum

  1. #1
    Piloto de Testes Jung13's Avatar
    Data de Registo
    Apr 2006
    Localização
    Viseu/Leiria
    Posts
    2,051

    Por Defeito Pedido de ajuda aos electrónicos do fórum

    Quero ter um Mosfet driver IR2110 a controlar o Mosfet IRF530N mas não consigo por isto a funcionar. Estou farto de simular circuitos que encontro pela net, já li o datasheet do IR2110 de uma ponta a outra e não percebo nada.

    Help


  2. #2
    Piloto Veterano ClioII's Avatar
    Data de Registo
    Jun 2005
    Localização
    , , .
    Posts
    22,732

    Por Defeito

    Explica-te... Qual é a ideia, qual é o circuito, porque é q se usam MOSFET e não outra coisa qq, etc...

  3. #3
    Piloto de Testes Jung13's Avatar
    Data de Registo
    Apr 2006
    Localização
    Viseu/Leiria
    Posts
    2,051

    Por Defeito

    A ideia seria ter um PWM a controlar o IR2110, por sua vez este controla o Mosfet que alimenta uma válvula reguladora de débito.

  4. #4
    Piloto de Testes Reidoasfalto's Avatar
    Data de Registo
    Jul 2003
    Localização
    Campeões Allez,...
    Posts
    3,626

    Por Defeito

    estás a usar qual simulador?...orcard?

  5. #5
    Piloto de Testes Jung13's Avatar
    Data de Registo
    Apr 2006
    Localização
    Viseu/Leiria
    Posts
    2,051

    Por Defeito

    Citação Originalmente Colocado por Reidoasfalto Ver Post
    estás a usar qual simulador?...orcard?
    Proteus


  6. #6
    Piloto de Testes Reidoasfalto's Avatar
    Data de Registo
    Jul 2003
    Localização
    Campeões Allez,...
    Posts
    3,626

    Por Defeito

    Citação Originalmente Colocado por Jung13 Ver Post
    Proteus
    esse nao conheço ..sorry

  7. #7
    Piloto Veterano ClioII's Avatar
    Data de Registo
    Jun 2005
    Localização
    , , .
    Posts
    22,732

    Por Defeito

    E então qual é o problema?

  8. #8
    Piloto de Testes Jung13's Avatar
    Data de Registo
    Apr 2006
    Localização
    Viseu/Leiria
    Posts
    2,051

    Por Defeito

    O problema é que ao simular no computador, ao iniciar está tudo perfeito, carrego para dar 5V na entrada, liga-se a luz. Até aqui tudo bem.

    Fica a 0V e continua a luz ligada...

  9. #9
    Piloto Veterano ClioII's Avatar
    Data de Registo
    Jun 2005
    Localização
    , , .
    Posts
    22,732

    Por Defeito

    Calculo que estejas a usar um único MOSFET como interruptor e, como é de canal N, o mais fácil é colocar a source à massa. Correcto?
    Nesse caso a tua carga (que para o efeito estás a usar uma lâmpada) está entre o dreno e uma tensão positiva de alguns volts (quantos?). Correcto?

  10. #10
    Piloto de Testes Jung13's Avatar
    Data de Registo
    Apr 2006
    Localização
    Viseu/Leiria
    Posts
    2,051

    Por Defeito

    Exacto.

    A carga é de 12V (é para um automóvel) e tem uma resistência interna na ordem dos 2 a 3 Ohm.

  11. #11
    Piloto Veterano ClioII's Avatar
    Data de Registo
    Jun 2005
    Localização
    , , .
    Posts
    22,732

    Por Defeito

    Nesse caso, para que precisas tu do IR2110? Eu tratava de aplicar directamente zero ou 5V na gate do MOSFET.
    Como a tua carga te vai pedir aí uns 6A no máximo (trata de ligar o MOSFET num bom dissipador de calor) um drive de 5V na gate já está mais do que bom para o usar o MOSFET como interruptor ON/OFF (a menos que precises de frequências de switching bestiais...).

  12. #12
    Piloto Veterano ClioII's Avatar
    Data de Registo
    Jun 2005
    Localização
    , , .
    Posts
    22,732

    Por Defeito

    Outra pergunta: na tua simulação colocaste mesmo um MOSFET no esquemático?

    Não terás, por acaso, colocado um tirístor ou um triac...?

  13. #13
    Piloto de Testes Jung13's Avatar
    Data de Registo
    Apr 2006
    Localização
    Viseu/Leiria
    Posts
    2,051

    Por Defeito

    A frequência do PWM é de 1.3KHz

    O proteus tem o mosfet que estou a usar. Foi só procurar por ele e apareceu-me logo a referência.

  14. #14
    Piloto Veterano ClioII's Avatar
    Data de Registo
    Jun 2005
    Localização
    , , .
    Posts
    22,732

    Por Defeito

    Citação Originalmente Colocado por Jung13 Ver Post
    A frequência do PWM é de 1.3KHz

    O proteus tem o mosfet que estou a usar. Foi só procurar por ele e apareceu-me logo a referência.
    E o MOSFET driver? Tb tem a referência directa ou foi um "achado na net"? É que esses achados muitas vezes enfermam de terem sido modelados por malta incompetente...

    Em todo o caso, eu ficava-me nas tintas para o driver e aplicava o sinal de controlo directamente à gate.

  15. #15
    Chefe de Equipa Vrumm's Avatar
    Data de Registo
    Sep 2003
    Localização
    Provavelmente... nas nuvens
    Posts
    25,862

    Por Defeito

    Vocjhês têm uma maneira exxxxxxxxxxxxquejita de falar!!!!
    rCrew, Texuga, santuarium and 1 others like this.

  16. #16
    Piloto Veterano ClioII's Avatar
    Data de Registo
    Jun 2005
    Localização
    , , .
    Posts
    22,732

    Por Defeito

    Citação Originalmente Colocado por Vrumm Ver Post
    Vocjhês têm uma maneira exxxxxxxxxxxxquejita de falar!!!!
    Sim! Excesso de virilidade, dizem...

  17. #17
    Piloto de Testes Jung13's Avatar
    Data de Registo
    Apr 2006
    Localização
    Viseu/Leiria
    Posts
    2,051

    Por Defeito

    O Driver não é o mesmo. O proteus só tem o IR2112, mas também não deve ser por isso... acho eu.

    Eu só não queria experimentar já na placa, porque o stock é limitado :P


    Os modelos não foram achados na net, vinham já com o próprio programa ;)

  18. #18
    Banido Ilyushin's Avatar
    Data de Registo
    May 2011
    Posts
    8,693

    Por Defeito

    O problema tem a ver com o difusor da terminação espacial da variação termoelétrica do catalisador termostático acoplado ao conjunto de vaporização espacial tripartida entre os limites superiores das pontas de masterização externa da formação assimétrica conjunta entre os diodos electronicos e condensadores sensitivos da primeira fase do sensor externo da conjugação macro sensitiva positiva , ligada à forma final de ejecção da corrente sensorial directa do Mosfet


    rCrew e Irascivel gostam disto.

  19. #19
    Piloto de Testes Jung13's Avatar
    Data de Registo
    Apr 2006
    Localização
    Viseu/Leiria
    Posts
    2,051

    Por Defeito

    Citação Originalmente Colocado por Ilyushin Ver Post
    O problema tem a ver com o difusor da terminação espacial da variação termoelétrica do catalisador termostático acoplado ao conjunto de vaporização espacial tripartida entre os limites superiores das pontas de masterização externa da formação assimétrica conjunta entre os diodos electronicos e condensadores sensitivos da primeira fase do sensor externo da conjugação macro sensitiva positiva , ligada à forma final de ejecção da corrente sensorial directa do Mosfet


    Irascivel gosta disto.

  20. #20
    Piloto Veterano ClioII's Avatar
    Data de Registo
    Jun 2005
    Localização
    , , .
    Posts
    22,732

    Por Defeito

    Citação Originalmente Colocado por Ilyushin Ver Post
    O problema tem a ver com o difusor da terminação espacial da variação termoelétrica do catalisador termostático acoplado ao conjunto de vaporização espacial tripartida entre os limites superiores das pontas de masterização externa da formação assimétrica conjunta entre os diodos electronicos e condensadores sensitivos da primeira fase do sensor externo da conjugação macro sensitiva positiva , ligada à forma final de ejecção da corrente sensorial directa do Mosfet


    Sim, trocado em miúdos, é isso!

  21. #21
    Piloto Veterano ClioII's Avatar
    Data de Registo
    Jun 2005
    Localização
    , , .
    Posts
    22,732

    Por Defeito

    Em todo o caso, se quiseres põe um esquema, que isto de estar a adivinhar no ar o que estás a fazer tem pouco nexo... apesar de que eu continuaria a atacar logo a gate!

  22. #22
    Piloto de Testes Jung13's Avatar
    Data de Registo
    Apr 2006
    Localização
    Viseu/Leiria
    Posts
    2,051

    Por Defeito

    Já descobri o problema.

    Estava a ligar directamente os 5V e o botão ao LIN. Parece que só funciona se fizer algo como 5V - res - GND e depois ir buscar o sinal para o LIN a isso.

    Obrigado ;)

  23. #23
    Piloto Veterano ClioII's Avatar
    Data de Registo
    Jun 2005
    Localização
    , , .
    Posts
    22,732

    Por Defeito

    Citação Originalmente Colocado por Jung13 Ver Post
    Já descobri o problema.

    Estava a ligar directamente os 5V e o botão ao LIN. Parece que só funciona se fizer algo como 5V - res - GND e depois ir buscar o sinal para o LIN a isso.

    Obrigado ;)
    Ou seja, quando largavas o botão o LIN ficava no ar, sem uma resistência de pull-down...? Pois...!

  24. #24
    Piloto de Testes Jung13's Avatar
    Data de Registo
    Apr 2006
    Localização
    Viseu/Leiria
    Posts
    2,051

    Por Defeito

    Citação Originalmente Colocado por ClioII Ver Post
    Ou seja, quando largavas o botão o LIN ficava no ar, sem uma resistência de pull-down...? Pois...!
    Isso mesmo! Já é a segunda vez que me acontece e mesmo assim não aprendo. :P

  25. #25
    Piloto de Testes Jung13's Avatar
    Data de Registo
    Apr 2006
    Localização
    Viseu/Leiria
    Posts
    2,051

    Por Defeito

    Citação Originalmente Colocado por ClioII Ver Post
    Em todo o caso, se quiseres põe um esquema, que isto de estar a adivinhar no ar o que estás a fazer tem pouco nexo... apesar de que eu continuaria a atacar logo a gate!
    Vai ficar assim:


  26. #26
    Piloto Veterano ClioII's Avatar
    Data de Registo
    Jun 2005
    Localização
    , , .
    Posts
    22,732

    Por Defeito

    Compreendo. Depois, em vez de um botão, vais ter um microcontrolador ou coisa semelhante para controlo automático. A ideia do fotoacoplador é boa por causa da protecção (isolamento galvãnico).

    Nota: no driver, não deixes as entradas no ar, especialmente a SD (que faz RESET às saídas). Embora no simulador não aconteça nada, na prática podes ter dissabores.

    Eu faria:
    HIN, SD e VS à massa, VB aos +12V.
    HO é uma saída, pode ficar no ar.

  27. #27
    Piloto de Troféu rCrew's Avatar
    Data de Registo
    Aug 2006
    Localização
    ...
    Posts
    7,191

    Por Defeito

    Quase que se pode considerar uma epic thread....

    O unico post que percebi foi aquele da maneira esquisita de falar -.-
    Irascivel gosta disto.

  28. #28
    Banido Ilyushin's Avatar
    Data de Registo
    May 2011
    Posts
    8,693

    Por Defeito

    Eu lembro-me de aprender o que eram Flip-Flops quando tirei um curso básico de electrónica. Tem a ver com isto? Lol

  29. #29
    Piloto Veterano ClioII's Avatar
    Data de Registo
    Jun 2005
    Localização
    , , .
    Posts
    22,732

    Por Defeito

    Citação Originalmente Colocado por Ilyushin Ver Post
    Eu lembro-me de aprender o que eram Flip-Flops quando tirei um curso básico de electrónica. Tem a ver com isto? Lol
    Citação Originalmente Colocado por Ilyushin Ver Post
    O problema tem a ver com o difusor da terminação espacial da variação termoelétrica do catalisador termostático acoplado ao conjunto de vaporização espacial tripartida entre os limites superiores das pontas de masterização externa da formação assimétrica conjunta entre os diodos electronicos e condensadores sensitivos da primeira fase do sensor externo da conjugação macro sensitiva positiva , ligada à forma final de ejecção da corrente sensorial directa do Mosfet

    Sim. Explicação detalhada a bold.

  30. #30
    Piloto de Troféu Irascivel's Avatar
    Data de Registo
    Oct 2008
    Localização
    Em frente ao pc se a bola estiver verde
    Posts
    5,467

    Por Defeito

    LOL

    Parece outra língua que só duas pessoas conheciam!

Página 1 de 2 12 ÚltimaÚltima

Regras de Colocação

  • Não pode criar tópicos
  • Não pode responder
  • Não pode colocar anexos
  • Não pode editar os seus posts
  •